Discover is Down
Incident Report for BlockChyp Status
Resolved
Discover has resolved the issue and transactions are now processing successfully.
Posted Feb 06, 2023 - 22:13 UTC
Update
We are starting to see some Discover transactions go through successfully. We will continue to monitor and let you know when the issue is resolved.
Posted Feb 06, 2023 - 21:49 UTC
Update
Discover is still experiencing issues and Discover credit card transactions are not going through. The problem is still being investigated and we will let you know as soon as there is an update or the issue is resolved.
Posted Feb 06, 2023 - 21:18 UTC
Monitoring
We see that the Discover network is not successfully processing transactions at this time. We are monitoring and will send an update as soon as we have one.
Posted Feb 06, 2023 - 20:00 UTC
This incident affected: Card Brand Networks (Discover).