Increased Approval Times on the Accel Network
Incident Report for BlockChyp Status
Resolved
Processing times are back to normal and the issue appears to be resolved.
Posted Feb 27, 2024 - 17:22 UTC
Investigating
We are aware of increased approval times on the Accel Network. This could impact certain PIN debit transactions. We are monitoring the issue and will let you know when we have an update or when the issue is resolved.
Posted Feb 27, 2024 - 17:18 UTC
This incident affected: Card Brand Networks (PIN Debit Network).