EBT/SNAP Service Interruption
Incident Report for BlockChyp Status
Resolved
This incident has been resolved.
Posted Jan 24, 2024 - 20:38 UTC
Update
Processing times are back to acceptable levels at this time. We will continue to monitor and send another update if something changes.

Thank you.
Posted Jan 24, 2024 - 20:38 UTC
Investigating
We are aware of and investigating slow processing times on EBT, Maestro and the Accel platforms. We will send an update when we have one.
Posted Jan 24, 2024 - 20:27 UTC
This incident affected: Card Brand Networks (EBT).