BlockChyp Customer Portal Inaccessible

Incident Report for BlockChyp Status

Resolved

The issue with the BlockChyp customer portal has been resolved. Thank you.
Posted Nov 19, 2025 - 15:31 UTC

Identified

The BlockChyp customer portal is currently inaccessible. Teams are working on identifying and remediating the issue.
Posted Nov 19, 2025 - 15:27 UTC
This incident affected: Merchant and Partner Dashboard.