Debit Network Outage

Incident Report for BlockChyp Status

Resolved

The issue has been resolved and processing and approval times are back to normal.
Posted Aug 29, 2024 - 14:55 UTC

Investigating

One of the main debit networks is experiencing a service interruption. This may impact merchant's ability to process specific debit card transactions. Please try the transaction again, or take another form of payment. This is being investigated and we will provide updates as soon as they are available.
Posted Aug 29, 2024 - 14:42 UTC
This incident affected: Card Brand Networks (PIN Debit Network).