Funding Delay

Incident Report for BlockChyp Status

Resolved

We’ve identified the root cause of the funding issue and are actively working on a resolution. The missing funds are expected to be deposited tomorrow.

We sincerely apologize for the inconvenience this has caused and appreciate your patience as we work to make things right.
Posted Apr 24, 2025 - 17:16 UTC

Update

Hello.

We are still investigating the funding delay. We will send another update when we have more details.

Thank you.
Posted Apr 24, 2025 - 15:12 UTC

Investigating

We’re aware of a funding issue currently affecting a subset of our merchants. Our team is actively investigating the root cause and working with our partners to determine a resolution timeline.

We understand how important timely deposits are and will provide an update as soon as we have more information.

Thank you for your patience.
Posted Apr 24, 2025 - 13:24 UTC
This incident affected: Funding (Funding).