Discover is Down
Incident Report for BlockChyp Status
Resolved
This incident has been resolved and Discover services have been restored. We do not yet have the root cause or what was done to resolve the issue. We will continue to monitor and let you know when we have updates.
Posted Mar 21, 2023 - 16:18 UTC
Identified
We have been made aware that Discover is down and Discover transactions are not successfully being processed. We are monitoring the situation and will send updates as soon as we have them.
Posted Mar 21, 2023 - 15:57 UTC
This incident affected: Card Brand Networks (Discover).